Back to overview
Downtime

KenyonWX is Unavailable

Feb 17, 2026 at 3:03pm UTC
Affected services
kenyonwx.com

Resolved
Feb 17, 2026 at 3:15pm UTC

The site is now stable and monitoring has stabilized.

Root Cause: The machine hosting the website experienced several network disconnections. With network connectivity stabilized, the intermittent timeouts resolved.

Updated
Feb 17, 2026 at 3:05pm UTC

Alerting triggered notifying the team that KenyonWX is now unavailable.

Created
Feb 17, 2026 at 3:03pm UTC

Monitoring is alerting to intermittent timeouts when attempting to visit KenyonWX.