Back to overview
Downtime
KenyonWX is Unavailable
Mar 21, 2026 at 7:52am UTC
Affected services
kenyonwx.com
Resolved
Mar 21, 2026 at 8:03am UTC
We have identified the root cause of the downtime. An upstream router was upgraded. The upgrade look less than 5 minutes and included several reboots that caused brief connection interruptions. Upon completion of the router upgrade, connectivity was restored.
Affected services
Created
Mar 21, 2026 at 7:52am UTC
Monitoring is alerting to consistent timeouts when attempting to visit KenyonWX.
Affected services