Back to overview
Downtime

KenyonWX is Unavailable

Apr 12, 2026 at 10:32am UTC
Affected services
kenyonwx.com

Resolved
Apr 12, 2026 at 10:37am UTC

We have identified the root cause of the downtime. A brief power interruption caused downtime for upstream routers. A reboot of the upstream router automatically occurred after the power interruption and connectivity was restored. Downtime was approximately 3 minutes and 30 seconds.

Created
Apr 12, 2026 at 10:32am UTC

Monitoring is alerting to consistent 502s when attempting to visit KenyonWX.