Back to overview
Downtime

KenyonWX is Unavailable

May 3, 2026 at 12:12am UTC
Affected services
kenyonwx.com

Resolved
May 3, 2026 at 12:20am UTC

We have identified the root cause of the downtime. An upstream router was upgraded. The upgrade look less than 5 minutes and included several reboots that caused brief connection interruptions. Upon completion of the router upgrade, connectivity was restored.

Created
May 3, 2026 at 12:12am UTC

Monitoring is alerting to consistent 502s when attempting to visit KenyonWX.