Back to overview
Resolved
KenyonWX is Unavailable
Jun 19, 2026 at 6:17pm UTC
Affected services
kenyonwx.com
Resolved
Jun 19, 2026 at 6:20pm UTC
We have identified the root cause of the downtime. An upstream router failed over. Upon completion of the router failover, connectivity was restored. Downtime was less than 3 minutes.
Affected services
Created
Jun 19, 2026 at 6:17pm UTC
Monitoring is alerting to consistent 502s when attempting to visit KenyonWX.
Affected services