KenyonWX is Unavailable
Resolved
Jun 22, 2026 at 2:12pm UTC
Cloudflare has mitigated the network traffic disruption. With the issue fixed upstream at Cloudflare, Kenyonwx is reachable again.
We will continue to monitor Cloudflare's status updates and will open a new incident if issues reoccur. Updates are occurring at https://new.cloudflarestatus.com/incidents/v3yl7jqmqj51
Affected services
Updated
Jun 22, 2026 at 1:40pm UTC
An upstream incident with Cloudflare is likely behind the outage. Updates can be tracked from Cloudflare here: https://new.cloudflarestatus.com/incidents/v3yl7jqmqj51
Affected services
Created
Jun 22, 2026 at 1:35pm UTC
Monitoring is alerting to consistent 502s when attempting to visit KenyonWX.
Affected services