Back to overview
Resolved

KenyonWX is Unavailable

Jun 28, 2026 at 2:05pm UTC
Affected services
kenyonwx.com

Resolved
Jun 28, 2026 at 3:20pm UTC

We have identified the root cause of the downtime. Severe weather resulted in the primary power source failing. The backup power source kicked in within 30 seconds, but an upstream router failed to power cycle correctly. A reboot of that router restored connectivity.

Created
Jun 28, 2026 at 2:05pm UTC

Monitoring is alerting to KenyonWX being unavailable.